BlogSo zählst du nie wieder den Spaltenindex beim SVERWEIS

So zählst du nie wieder den Spaltenindex beim SVERWEIS

Im vorherigen Beitrag hast du den SVERWEIS kennen- und bestimmt auch schon schätzen gelernt.

SVERWEIS ein richtiges Ärgernis werden. Hier gibst du an, den Inhalt der wievielten Spalte du sehen möchtest. Wenn die Tabelle sehr breit ist und dazu noch einige Spalten ausgeblendet sind, kann dies eine echte Herausforderung werden.

In diesem Beispiel wird der SVERWEIS die Zeile mit dem Suchkriterium 104 finden. Die Funktion VERGLEICH findet die Nummer der Spalte mit dem Text Nachname. Damit brauchst du die Spalten bis zur Spalte Nachname nicht zählen.

Bonus: Weiter unten in diesem Beitrag erfährst du mehr zur Funktion VERGLEICH.

Nie wieder Spalten zählen

Du brauchst neben einer Tabelle mit den Daten auch die Eingabefelder inklusiv der Spaltenüberschriften.

  • Klicke in die Zelle, in der du das Ergebnis sehen möchtest in diesem Beispiel C5.
  • Tippe =sverweis( ein.
  • Der erste Parameter ist das Suchkriterium, in diesem Beispiel B5. Klicke einmal auf B5 und drücke ;. Die Formel sieht zurzeit so aus: =SVERWEIS(B5;
  • Markiere nun die ganze Tabelle ohne die Überschriften, in der du die Werte suchst. In diesem Beispiel H5 bis AG15. Drücke nach dem Markieren direkt die Taste [F4], um die Zellen festzusetzen. Tippe nun das ;. Die Formel sieht zurzeit so aus: =SVERWEIS(B5;$H$5:$AG$15;
  • Tippe jetzt den Funktionsnamen VERGLEICH(.
  • Gesucht wird zurzeit der Nachname und dieses Suchkriterium steht in C4. Klicke in die Zelle C4 und tippe das ; ein.
  • Markiere nun alle Überschriften der Tabelle, die du eben markiert hast. Drücke im Anschluss [F4] und anschließend das ;.
  • Tippe nun noch 0); ein. Die Formel sieht zurzeit so aus: =SVERWEIS(B5;$H$5:$AG$15;VERGLEICH(C4;$H$4:$AG$4;0);
  • Der letzte Parameter des SVERWEIS ist der Text Falsch), um nur die 100%igen Treffer zu erhalten.
  • Drücke [◻︎], um die Formel abzuschließen.

Die Formel sieht so aus: =SVERWEIS(B5;$H$5:$AG$15;VERGLEICH(C4;H4:AG4;0);FALSCH)

Wenn du jetzt in der Zelle C4 den Text Ort eintippst und [◻︎] drückst, wird in C5 der Ort zum Suchkriterium in B5 gezeigt.

So arbeitet die Funktion VERGLEICH

Die Funktion VERGLEICH findet die Positionsnummer eines Suchkriteriums.

Der Begriff Nachname steht in den markierten Zellen an achter Position. Das bedeutet, das Ergebnis ist die 8.

Dies soll mit der Funktion VERGLEICH jetzt bestätigt werden.

  1. Klicke in die Zelle, in der du das Ergebnis sehen möchtest in diesem Beispiel C5. In C4 steht der Suchbegriff Nachname.
  2. Tippe =vergleich( ein.
  3. Der erste Parameter ist das Suchkriterium, in diesem Beispiel C4. Klicke einmal auf C4 und drücke ;. Die Formel sieht zurzeit so aus: =VERGLEICH(C4
  4. Markiere nun nur die Überschriften der Tabelle. In diesem Beispiel H4 bis AG4. Drücke nach dem Markieren direkt die Taste [F4], um die Zellen festzusetzen. Tippe nun das ;. Die Formel sieht zurzeit so aus: =VERGLEICH(C4;$H$4:$AG$4;
  5. Der letzte Parameter ist die 0), um nur die 100%igen Treffer zu erhalten.
  6. Drücke [◻︎], um die Formel abzuschließen.

Wenn du jetzt den Begriff Ort in die Zelle C4 eintippst, erhältst du die Zahl 25, da das Wort Ort an der 25. Stelle in den markierten Zellen steht.

Schulungen die dich interessieren könnten

Bewertungen

Kundenstimme
Mausolf B.
Struers GmbH
star-participantstar-participantstar-participantstar-participantstar-participant
Tolle Schulung - kompetenter Trainer, der geduldig auf alle Fragen einging, diese beantworten konnte und darüber hinaus viele neue Anregungen mit auf den Weg gab. Die Schulung hat Spaß gemacht.
Kundenstimme
Torsten B.
Westdeutscher Rundfunk WDR
star-participantstar-participantstar-participantstar-participantstar-participant
Das Seminar hat nicht nur Spaß gemacht, sondern auch wirklich 'ne Menge gebracht :-)
Kundenstimme
Philipp M.
Wacom Europe GmbH
star-participantstar-participantstar-participantstar-participantstar-participant
Sehr gute Organisation, guter Trainer - alles super!
Kundenstimme
Lucas F.
Fa. Feld Textil GmbH
star-participantstar-participantstar-participantstar-participantstar-participant
Kann man nur weiterempfehlen! In kürzestem Zeitraum lernt man alle Basisdaten konkret und ausführlich.