BlogExcel: ZÄHLENWENN

Excel: ZÄHLENWENN

Excel ZAEHLENWENN Funktion

Excel: ZÄHLENWENN – so funktioniert es

Die Excel-Option „ZÄHLENWENN“ ist eine bedingte Zähl-Funktion in Microsoft Excel, die es dir ermöglicht, die Anzahl der Zellen in einem bestimmten Bereich deiner Tabelle zu zählen. Dabei kannst du die Kriterien frei definieren und zwischen den Anführungszeichen einsetzen. Die Syntax lautet wie folgt:

=ZÄHLENWENN(Bereich, Merkmal)

  • „Bereich“ ist der Bereich, in dem die Zellen deiner Tabelle gezählt werden sollen.
  • „Merkmal“ ist die Bedingung, die die Zellen erfüllen müssen, damit sie gezählt werden.

Im folgenden Beispiel wollen wir die Anzahl der Äpfel ermitteln: =ZÄHLENWENN(A1:A10,“Apfel“) zählt die Anzahl der Zellen in der Spalte A von Zeile 1 bis Zeile 10, die den Wert „Apfel“ enthalten.

Tipp: Wenn du mehr zur Excel Funktion Zählenwenn oder zur Zählenwenns-Funktion wissen möchtest, empfehlen wir dir unseren Excel Kompakt Kurs.

ZÄHLENWENN kann auch mit Wildcards verwendet werden, um nach Teilzeichenfolgen in Zellen zu suchen. Das ist hilfreich, wenn du nach einem bestimmten Inhalt suchen möchtest. Beispiel: =ZÄHLENWENN(A1:A10,“*el“) zählt die Anzahl der Zellen in der Spalte A von Zeile 1 bis Zeile 10, die mit „el“ enden. Jede andere Zelle wird bei dieser Funktion außer Acht gelassen.

Es ist auch möglich, die Funktion mit mehreren Kriterien zu erstellen und anzuwenden, indem man die Funktion „UND“ oder „ODER“ in die Kriteriumszeile einfügt. Beispielsweise: =ZÄHLENWENN(A1:A10,“Apfel“, OR „Birne“). So kannst du das Suchkriterium ganz einfach anpassen.

Für wen ZÄHLENWENN und ZÄHLENWENNS relevant ist

Da es sich um eine bedingte Zählfunktion handelt, die in vielen Situationen nützlich sein kann, benötigt sie praktisch jeder, der Microsoft Excel effizient nutzen will. In etwa, wenn du Informationen aus großen Datenmengen extrahieren möchtest.

Beispiele für den Einsatz der Funktion „ZÄHLENWENN“:

  • Zählen der Verkäufe eines bestimmten Produkts in einer Tabelle mit Verkaufsdaten.
  • Zählen der Kunden, die eine bestimmte Region oder Stadt leben.
  • Zählen der Fehler in einer Tabelle mit Fehlerprotokollen.
  • Usw.

Dies sind nur einige Anwendungsmöglichkeiten. Denn „ZÄHLENWENN“ ist flexibel und du kannst die in vielen verschiedenen Situationen verwenden, in denen du die Anzahl der Zellen zählen willst, die bestimmte Kriterien erfüllen.

Gutschein

Wie du ZÄHLENWENN und ZÄHLENWENNS sowie weitere Excel-Funktionen verwendest, zeigen wir dir in unserer Excel Kompakt Schulung. Einfach den Code kopieren, bei der Anmeldung angeben und 50€ sparen.

Excel_50_2022
50 € Code kopieren
Code kopiert!
Code kopieren und bei der Anmeldung einfügen

Schritt für Schritt: Die Excel-Formel ZÄHLENWENN erklärt 

Hier sind die Schritte, um die folgende Formel „ZÄHLENWENN“ in Microsoft Excel Schritt für Schritt zu erstellen:

Wähle die Zelle aus, in der das Ergebnis der Formel angezeigt werden soll.
Gib die Formel "=ZÄHLENWENN(" ein.
Gib die Formel „=ZÄHLENWENN(“ ein.
Wähle den Bereich aus, in dem die Zellen gezählt werden sollen.
Wähle den Bereich aus, in dem die Zellen gezählt werden sollen.

Dieser Bereich kann eine einzelne Spalte, eine einzelne Zeile oder eine Gruppe von Zellen (Zeilen und Spalten) sein. Um einen Bereich auszuwählen, klicke auf die erste Zelle und halte die linke Maustaste gedrückt, während du die Maus über den Bereich bewegst.

Gib ein Komma "," ein und gib das Merkmal ein, nach dem die Zellen gezählt werden sollen. Beispielsweise könntest du "Apfel" als Merkmal eingeben, um die Anzahl der Zellen zu zählen, die den Wert "Apfel" enthalten.
Gib ein Komma „,“ ein und gib das Merkmal ein, nach dem die Zellen gezählt werden sollen. Beispielsweise könntest du „Apfel“ als Merkmal eingeben, um die Anzahl der Zellen zu zählen, die den Wert „Apfel“ enthalten.
Gib ein Komma "," ein und gib das Merkmal ein, nach dem die Zellen gezählt werden sollen. Beispielsweise könntest du "Apfel" als Merkmal eingeben, um die Anzahl der Zellen zu zählen, die den Wert "Apfel" enthalten.
Schließe die Formel mit einer schließenden Klammer „)“ ab.
Drücke die Eingabetaste, um das Ergebnis der Formel anzuzeigen. Das Ergebnis sollte die Anzahl der Zellen im ausgewählten Bereich anzeigen, die das angegebene Merkmal erfüllen.
Drücke die Eingabetaste, um das Ergebnis der Formel anzuzeigen. Das Ergebnis sollte die Anzahl der Zellen im ausgewählten Bereich anzeigen, die das angegebene Merkmal erfüllen.


Den Durchschnitt ohne Nullwerte berechnen

Um den Durchschnitt in Excel ohne Nullwerte zu berechnen, kannst du die Funktion „MITTELWERT“ in Kombination mit der Funktion ZÄHLENWENN anwenden. Die Formel lautet wie folgt:

=MITTELWERT(ZÄHLENWENN(Bereich; „<>0“))

  • „Bereich“ ist der Bereich, in dem die Zellen gezählt werden sollen, die nicht den Wert 0 haben.

Beispiel: =MITTELWERT(ZÄHLENWENN(A1:A10; „<>0“)) berechnet den Durchschnitt der Zellen in der Spalte A von Zeile 1 bis Zeile 10, die nicht den Wert 0 haben.

Diese Formel zählt zuerst die Anzahl der Zellen im angegebenen Bereich, die nicht den Wert 0 haben, und berechnet dann den Durchschnitt dieser Zellen.

Du kannst eine ähnliche Formel anwenden, um den Durchschnitt von Zellen zu berechnen, die bestimmte Kriterien erfüllen, indem du „SUMMEWENNS“ anstelle von „ZÄHLENWENN“ und die Funktion „SUMME“ anstelle von „MITTELWERT“ verwendest. Beispiel: =SUMME(SUMMEWENNS(Bereich;Kriterium))/ZÄHLENWENN(Bereich;Kriterium)

ZÄHLENWENN mit Excel — FAQs:

ZÄHLENWENN oder ZÄHLENWENNS – wann verwende ich was?

Die Funktionen „ZÄHLENWENN“ und „ZÄHLENWENNS“ in Excel sind beide bedingte Zählfunktionen, die du nutzen kannst, um die Anzahl der Zellen in einem bestimmten Bereich zu zählen, die ganz bestimmten Kriterien entsprechen.

Die „ZÄHLENWENN“ Funktion wird verwendet, um die Anzahl der Zellen in einem bestimmten Bereich zu zählen, die ein bestimmtes Merkmal erfüllen. Die Syntax lautet: =ZÄHLENWENN(Bereich, Merkmal). Weiter oben haben wir dafür Äpfel und Birnen als Platzhalter genutzt.

Beispiel: =ZÄHLENWENN(A1:A10,“Apfel“) zählt die Anzahl der Zellen in der Spalte A von Zeile 1 bis Zeile 10, die den Wert „Apfel“ enthalten.

Die Zählenwenns Funktion ist eine erweiterte Version von „ZÄHLENWENN“ und ermöglicht es dir, mehrere Kriterien in einer einzigen Formel zusammenzufassen. Die Syntax lautet: =ZÄHLENWENNS(Datenbereich, Eigenschaft1, Bereich1, [Eigenschaft2, Bereich2], …)

Beispiel für die Zählenwenns Funktion: =ZÄHLENWENNS(A1:A10, „Apfel“, A1:A10, „Birne“, B1:B10) zählt die Anzahl der Zellen in der Spalte A von Zeile 1 bis Zeile 10, die den Wert „Apfel“ enthalten und die Anzahl der Zellen in der Spalte B von Zeile 1 bis Zeile 10, die den Wert „Birne“ enthalten.

In einfachen Worten, verwendest du ZÄHLENWENN für ein einziges Suchkriterium, und die Zählenwenns Funktion für mehrere Suchkriterien.

ZÄHLENWENN mit ODER: geht das?

Ja, es funktioniert, „ZÄHLENWENN“ mit dem logischen „ODER“ zu verknüpfen. Damit kannst du dann die Anzahl der Zellen zu zählen, die entweder ein bestimmtes Merkmal oder ein anderes erfüllen.

Um die Anzahl der Zellen zu zählen, die entweder Merkmal 1 oder Merkmal 2 erfüllen, kannst du die Funktion „ZÄHLENWENN“ zweimal nutzen und die Ergebnisse mit der Funktion „SUMME“ zusammenfügen.

Die Syntax lautet wie folgt:

=SUMME(ZÄHLENWENN(Bereich, Merkmal1), ZÄHLENWENN(Bereich, Merkmal2))

Beispiel: =SUMME(ZÄHLENWENN(A1:A10, „Apfel“),ZÄHLENWENN(A1:A10, „Birne“)) zählt die Anzahl der Zellen in der Spalte A von Zeile 1 bis Zeile 10, die entweder den Wert „Apfel“ oder den Wert „Birne“ enthalten.

Es ist auch möglich, die Funktion „ZÄHLENWENNS“ zu verwenden, um mehrere Kriterien in einer einzigen Formel zu verwenden. Wenn du die Funktion „ODER“ in der Kriteriumszeile verwenden möchtest, dann kannst du es in Klammern setzen.

Beispiel : =ZÄHLENWENNS(Bereich,(Kriterium1, Kriterium2),“ODER“)

In diesem Muster, ZÄHLENWENNS wird die Anzahl der Zellen deiner Liste berechnet die entweder Kriterium1 oder Kriterium2 erfüllen.

Gutschein

Wie du ZÄHLENWENN und ZÄHLENWENNS sowie weitere Excel-Funktionen verwendest, zeigen wir dir in unserer Excel Kompakt Schulung. Einfach den Code kopieren, bei der Anmeldung angeben und 50€ sparen.

Excel_50_2022
50 € Code kopieren
Code kopiert!
Code kopieren und bei der Anmeldung einfügen

Bewertungen

Kundenstimme männlich
Mausolf B.
Struers GmbH
star-participantstar-participantstar-participantstar-participantstar-participant
Tolle Schulung - kompetenter Trainer, der geduldig auf alle Fragen einging, diese beantworten konnte und darüber hinaus viele neue Anregungen mit auf den Weg gab. Die Schulung hat Spaß gemacht.
Kundenstimme männlich
Lucas F.
Fa. Feld Textil GmbH
star-participantstar-participantstar-participantstar-participantstar-participant
Kann man nur weiterempfehlen! In kürzestem Zeitraum lernt man alle Basisdaten konkret und ausführlich.
Kundenstimme männlich
Torsten B.
Westdeutscher Rundfunk WDR
star-participantstar-participantstar-participantstar-participantstar-participant
Das Seminar hat nicht nur Spaß gemacht, sondern auch wirklich 'ne Menge gebracht :-)
Kundenstimme männlich
Markus H.
CARAT Dreieich
star-participantstar-participantstar-participantstar-participantstar-participant
Der Trainer machte einen sehr netten und kompetenten Eindruck und ging auf unsere Wünsche und Anregungen sehr praxisorientiert ein .